Coaptite injection

valerieeanderson

Networker
Messages
35
Location
Buckeye, AZ
Best answers
0
We received a denial from Care First (Medicaid) bundling the L8606 and 51715, stating we should use -NU on L8606. I was told that we cannot use the -NU modifier here at our practice. After doing some research I can't see why they would say that modifer needed to be used. There is no NCCI bundle between these two codes and as far as I know they wouldn't bundle. Does anyone have any information/links I can use to either educate myself/practice or has anyone else received a similar denial? Is there a modifer I should be using when billing these? TIA!
 

liqgold2@aol.com

Networker
Messages
71
Best answers
0
You are correct. These two codes are not bundled but the bundling they state may be a specific bundling/problem for this carrier. I would asuggest billing with the _NU modifier and see what happens. Personally have not had this problem. I am not sure what modifier -NU stands for.
 
Top